aboutsummaryrefslogtreecommitdiffstats
path: root/community/julia/fix-or-disable-broken-tests.patch
diff options
context:
space:
mode:
Diffstat (limited to 'community/julia/fix-or-disable-broken-tests.patch')
-rw-r--r--community/julia/fix-or-disable-broken-tests.patch32
1 files changed, 16 insertions, 16 deletions
diff --git a/community/julia/fix-or-disable-broken-tests.patch b/community/julia/fix-or-disable-broken-tests.patch
index fffadfb462..be82b33d29 100644
--- a/community/julia/fix-or-disable-broken-tests.patch
+++ b/community/julia/fix-or-disable-broken-tests.patch
@@ -22,37 +22,37 @@ test/read.jl: ditto.
close(p)
--- a/test/Makefile
+++ b/test/Makefile
-@@ -4,7 +4,7 @@
- include $(JULIAHOME)/Make.inc
- # TODO: this Makefile ignores BUILDDIR, except for computing JULIA_EXECUTABLE
-
--TESTS = all linalg $(filter-out TestHelpers runtests testdefs,$(patsubst $(SRCDIR)/%.jl,%,$(wildcard $(SRCDIR)/*.jl $(SRCDIR)/linalg/*.jl)))
-+TESTS = all linalg $(filter-out TestHelpers runtests testdefs libdl,$(patsubst $(SRCDIR)/%.jl,%,$(wildcard $(SRCDIR)/*.jl $(SRCDIR)/linalg/*.jl)))
-
- default: all
+@@ -6,7 +6,7 @@
+ TESTGROUPS = linalg sparse unicode strings dates
+ TESTS = all $(TESTGROUPS) \
+- $(filter-out TestHelpers runtests testdefs, \
++ $(filter-out TestHelpers runtests testdefs libdl, \
+ $(patsubst $(SRCDIR)/%.jl,%,$(wildcard $(SRCDIR)/*.jl))) \
+ $(foreach group,$(TESTGROUPS), \
+ $(patsubst $(SRCDIR)/%.jl,%,$(wildcard $(SRCDIR)/$(group)/*.jl)))
--- a/test/cmdlineargs.jl
+++ b/test/cmdlineargs.jl
-@@ -301,7 +301,7 @@
+@@ -404,7 +404,7 @@
bt = readstring(pipeline(ignorestatus(`$(Base.julia_cmd()) --startup-file=no --precompiled=$precomp
-E 'include("____nonexistent_file")'`), stderr=catcmd))
- @test contains(bt, "in include_from_node1")
+ @test contains(bt, "include_from_node1")
- if is_windows() && Sys.WORD_SIZE == 32 && precomp == "yes"
+ if ((is_windows() && Sys.WORD_SIZE == 32) || is_linux()) && precomp == "yes"
# fixme, issue #17251
- @test_broken contains(bt, "in include_from_node1(::String) at $(joinpath(".","loading.jl"))")
+ @test_broken contains(bt, "include_from_node1(::String) at $(joinpath(".","loading.jl"))")
else
--- a/test/choosetests.jl
+++ b/test/choosetests.jl
-@@ -31,7 +31,7 @@
- "replutil", "sets", "test", "goto", "llvmcall", "grisu",
+@@ -32,7 +32,7 @@
+ "replutil", "sets", "test", "goto", "llvmcall", "llvmcall2", "grisu",
"nullable", "meta", "stacktraces", "profile", "libgit2", "docs",
"markdown", "base64", "serialize", "misc", "threads",
- "enums", "cmdlineargs", "i18n", "workspace", "libdl", "int",
+ "enums", "cmdlineargs", "i18n", "workspace", "int",
- "checked", "intset", "floatfuncs", "compile", "parallel", "inline",
- "boundscheck", "error", "ambiguous", "cartesian"
- ]
+ "checked", "intset", "floatfuncs", "compile", "distributed", "inline",
+ "boundscheck", "error", "ambiguous", "cartesian", "asmvariant", "osutils",
+ "channels", "iostream", "specificity"
--- a/test/file.jl
+++ b/test/file.jl
@@ -174,8 +174,8 @@