aboutsummaryrefslogtreecommitdiffstats
path: root/community/kcompletion/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kcompletion/APKBUILD')
-rw-r--r--community/kcompletion/APKBUILD15
1 files changed, 12 insertions, 3 deletions
diff --git a/community/kcompletion/APKBUILD b/community/kcompletion/APKBUILD
index d98216ed39..407baac109 100644
--- a/community/kcompletion/APKBUILD
+++ b/community/kcompletion/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kcompletion
-pkgver=5.62.0
+pkgver=5.63.0
pkgrel=0
pkgdesc="Text completion helpers and widgets"
arch="all"
@@ -13,8 +13,15 @@ checkdepends="xvfb-run"
source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kcompletion-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+prepare() {
+ default_prepare
+
+ mkdir "$builddir"/build
+}
+
build() {
- cmake \
+ cd "$builddir"/build
+ cmake "$builddir" \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
@@ -23,10 +30,12 @@ build() {
}
check() {
+ cd "$builddir"/build
CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
}
package() {
+ cd "$builddir"/build
DESTDIR="$pkgdir" make install
}
-sha512sums="b7511dea047e3c458d2a9912446752ce89245b4aed97b44beb180e7a79751d257f7d35b184531957cabb0d94db50f224523a0300276c006b7c1e888c570a6daa kcompletion-5.62.0.tar.xz"
+sha512sums="981240887c8e35d5e2bdb591f1ae4076f9bec9b7b2203b3f4a726605adf06538caab60edbc979b931e63c35694264c5bc53f97e686bec3e2eee79c82e6486979 kcompletion-5.63.0.tar.xz"