aboutsummaryrefslogtreecommitdiffstats
path: root/community/kde-cli-tools/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kde-cli-tools/APKBUILD')
-rw-r--r--community/kde-cli-tools/APKBUILD20
1 files changed, 14 insertions, 6 deletions
diff --git a/community/kde-cli-tools/APKBUILD b/community/kde-cli-tools/APKBUILD
index 9653ff0611..4c05154611 100644
--- a/community/kde-cli-tools/APKBUILD
+++ b/community/kde-cli-tools/APKBUILD
@@ -1,21 +1,27 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kde-cli-tools
-pkgver=5.16.5
+pkgver=5.17.0
pkgrel=0
pkgdesc="Tools based on KDE Frameworks 5 to better interact with the system"
arch="all !ppc64le !s390x" # Limited by plasma-workspace -> libksysguard -> qt5-qtwebengine
url="https://cgit.kde.org/kde-cli-tools"
license="(GPL-2.0-only OR GPL-3.0-only) AND GPL-2.0-or-later AND GPL-2.0-only AND LGPL-2.1-only"
-depends_dev="qt5-qtbase-dev qt5-qtsvg-dev qt5-qtx11extras-dev kconfig-dev kiconthemes-dev kinit-dev ki18n-dev kcmutils-dev kio-dev kservice-dev kwindowsystem-dev kactivities-dev kdeclarative-dev kdesu-dev plasma-workspace-dev"
-makedepends="$depends_dev extra-cmake-modules kdoctools-dev"
+makedepends="extra-cmake-modules kdoctools-dev qt5-qtbase-dev qt5-qtsvg-dev qt5-qtx11extras-dev kconfig-dev kiconthemes-dev kinit-dev ki18n-dev kcmutils-dev kio-dev kservice-dev kwindowsystem-dev kactivities-dev kdeclarative-dev kdesu-dev plasma-workspace-dev"
checkdepends="xvfb-run"
-source="https://download.kde.org/stable/plasma/$pkgver/$pkgname-$pkgver.tar.xz"
+source="https://download.kde.org/stable/plasma/$pkgver/kde-cli-tools-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
options="!check" # Broken
+prepare() {
+ default_prepare
+
+ mkdir "$builddir"/build
+}
+
build() {
- cmake \
+ cd "$builddir"/build
+ cmake "$builddir" \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
@@ -23,10 +29,12 @@ build() {
}
check() {
+ cd "$builddir"/build
CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
}
package() {
+ cd "$builddir"/build
DESTDIR="$pkgdir" make install
}
-sha512sums="11b5acd6bb0a6a7e566e8b6e6f24299bf23128ba1ed9cb0ae78c8e344da3c0769791b5543fac2152cae638b90615cf6b8c4b455a95f6d09afa515eb391370406 kde-cli-tools-5.16.5.tar.xz"
+sha512sums="e2d1697d2a172646f5fb7d0a3421c135aa0bf6f17a86d413123ca6c26a4146f52c58d136734712cf58a616f7e4e34e534ba179c772f31af19f77157ced1f439a kde-cli-tools-5.17.0.tar.xz"