aboutsummaryrefslogtreecommitdiffstats
path: root/community/kdecoration/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kdecoration/APKBUILD')
-rw-r--r--community/kdecoration/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/community/kdecoration/APKBUILD b/community/kdecoration/APKBUILD
new file mode 100644
index 0000000000..d9ba698518
--- /dev/null
+++ b/community/kdecoration/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=kdecoration
+pkgver=5.16.5
+pkgrel=0
+pkgdesc="Plugin based library to create window decorations"
+arch="all"
+url="https://www.kde.org/workspaces/plasmadesktop/"
+license="LGPL-2.1-only OR LGPL-3.0-only"
+depends_dev="qt5-qtbase-dev ki18n-dev"
+makedepends="$depends_dev extra-cmake-modules"
+source="https://download.kde.org/stable/plasma/$pkgver/$pkgname-$pkgver.tar.xz"
+subpackages="$pkgname-dev $pkgname-lang"
+options="!check" # Fails due to requiring running X11
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+sha512sums="aaf7c24f7f6c77661902bc219ac1448cf2542645fb96fcc18f5751ed775a722c745f6d71c2d6b0285103a99b68446bb3ae59ff9bd8279dcb635dee6927fc000e kdecoration-5.16.5.tar.xz"