aboutsummaryrefslogtreecommitdiffstats
path: root/community/kemoticons/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kemoticons/APKBUILD')
-rw-r--r--community/kemoticons/APKBUILD15
1 files changed, 12 insertions, 3 deletions
diff --git a/community/kemoticons/APKBUILD b/community/kemoticons/APKBUILD
index b1678d2107..19a4f61f39 100644
--- a/community/kemoticons/APKBUILD
+++ b/community/kemoticons/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kemoticons
-pkgver=5.62.0
+pkgver=5.63.0
pkgrel=0
pkgdesc="Support for emoticons and emoticons themes"
arch="all"
@@ -13,8 +13,15 @@ checkdepends="xvfb-run"
source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kemoticons-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc"
+prepare() {
+ default_prepare
+
+ mkdir "$builddir"/build
+}
+
build() {
- cmake \
+ cd "$builddir"/build
+ cmake "$builddir" \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
@@ -23,10 +30,12 @@ build() {
}
check() {
+ cd "$builddir"/build
CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
}
package() {
+ cd "$builddir"/build
DESTDIR="$pkgdir" make install
}
-sha512sums="e21f181d120980420a293aed02e1f13aa953535efc09d6c1d03aebd8217c99b73fa4a72243d0f23a3f9627d5b3bec3b9037341e814d00e5c8923cfa6817c741b kemoticons-5.62.0.tar.xz"
+sha512sums="b0a52c3cdba7e5c929538c529b38406a4a844c264fdc9afc1a500332f5b6c50d27cd7bd9393cdf7db158a04e51fe1ecc734e26bf970b6fa8a73cf9830e6bdb28 kemoticons-5.63.0.tar.xz"