aboutsummaryrefslogtreecommitdiffstats
path: root/community/knot
diff options
context:
space:
mode:
Diffstat (limited to 'community/knot')
-rw-r--r--community/knot/APKBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/community/knot/APKBUILD b/community/knot/APKBUILD
index d2dd7ce405..ff770332b4 100644
--- a/community/knot/APKBUILD
+++ b/community/knot/APKBUILD
@@ -58,9 +58,9 @@ check() {
package() {
make DESTDIR="$pkgdir" install
- rm -Rf "$pkgdir"/run
- chown $pkgusers:$pkggroups "$pkgdir"/var/lib/$pkgname
- chmod 750 "$pkgdir"/var/lib/$pkgname
+ rm -rf "$pkgdir"/run
+ chown "${pkgusers%% *}:${pkggroups%% *}" "$pkgdir/var/lib/$pkgname"
+ chmod 750 "$pkgdir/var/lib/$pkgname"
install -Dm 644 "$srcdir"/knotd.confd \
"$pkgdir"/etc/conf.d/knotd