aboutsummaryrefslogtreecommitdiffstats
path: root/community/knotifyconfig/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/knotifyconfig/APKBUILD')
-rw-r--r--community/knotifyconfig/APKBUILD20
1 files changed, 6 insertions, 14 deletions
diff --git a/community/knotifyconfig/APKBUILD b/community/knotifyconfig/APKBUILD
index 8646e15d78..261795c4c8 100644
--- a/community/knotifyconfig/APKBUILD
+++ b/community/knotifyconfig/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=knotifyconfig
-pkgver=5.68.0
+pkgver=5.69.0
pkgrel=0
pkgdesc="Configuration system for KNotify"
arch="all !armhf" # armhf blocked by extra-cmake-modules
@@ -12,29 +12,21 @@ makedepends="$depends_dev extra-cmake-modules qt5-qttools-dev doxygen"
source="https://download.kde.org/stable/frameworks/${pkgver%.*}/knotifyconfig-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
-prepare() {
- default_prepare
-
- mkdir "$builddir"/build
-}
-
build() {
- cd "$builddir"/build
- cmake "$builddir" \
+ cmake -B build \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_QCH=ON
- make
+ make -C build
}
check() {
- cd "$builddir"/build
+ cd build
CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
package() {
- cd "$builddir"/build
- DESTDIR="$pkgdir" make install
+ DESTDIR="$pkgdir" make -C build install
}
-sha512sums="de9269b4654fec05b7b87aaf91c35158b9fcc7a9afb18d42f7810c493dfdbe6ff82ed6fa044d369186b8fb087d524d6a5597365c3f967e95d93be54a03b13568 knotifyconfig-5.68.0.tar.xz"
+sha512sums="84e2ee271c811407789eabcb61d7412bf7a9d5c2f8d2d1961cc8d416762e0bd32ab3ffdbdfbba9de27e3ea406187f64b34793ab62659770fbaf19859100612e7 knotifyconfig-5.69.0.tar.xz"