aboutsummaryrefslogtreecommitdiffstats
path: root/community/kplotting/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kplotting/APKBUILD')
-rw-r--r--community/kplotting/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/community/kplotting/APKBUILD b/community/kplotting/APKBUILD
new file mode 100644
index 0000000000..41e486e25a
--- /dev/null
+++ b/community/kplotting/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=kplotting
+pkgver=5.60.0
+pkgrel=0
+pkgdesc="Lightweight plotting framework"
+arch="all"
+url="https://community.kde.org/Frameworks"
+license="LGPL-2.1-or-later"
+depends_dev="qt5-qtbase-dev"
+makedepends="$depends_dev extra-cmake-modules doxygen qt5-qttools-dev"
+checkdepends="xvfb-run"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
+subpackages="$pkgname-dev $pkgname-doc"
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_QCH=ON
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="0a70977684690c2087f968501b64d814fabddd43087aa2df4d498985f7cfaa8cf81e16215e2d12cccf9932748172e47b40a85d049207e3dc351785acdeaa622a kplotting-5.60.0.tar.xz"