aboutsummaryrefslogtreecommitdiffstats
path: root/community/kplotting/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kplotting/APKBUILD')
-rw-r--r--community/kplotting/APKBUILD15
1 files changed, 12 insertions, 3 deletions
diff --git a/community/kplotting/APKBUILD b/community/kplotting/APKBUILD
index f76c821a85..abb73fe798 100644
--- a/community/kplotting/APKBUILD
+++ b/community/kplotting/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kplotting
-pkgver=5.62.0
+pkgver=5.63.0
pkgrel=0
pkgdesc="Lightweight plotting framework"
arch="all"
@@ -13,8 +13,15 @@ checkdepends="xvfb-run"
source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kplotting-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc"
+prepare() {
+ default_prepare
+
+ mkdir "$builddir"/build
+}
+
build() {
- cmake \
+ cd "$builddir"/build
+ cmake "$builddir" \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
@@ -23,11 +30,13 @@ build() {
}
check() {
+ cd "$builddir"/build
CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
}
package() {
+ cd "$builddir"/build
DESTDIR="$pkgdir" make install
}
-sha512sums="b979698f4341d3fe968cd8e7c0ac26948bf120d1ddd5e605467299bff2a09a7e301a288c3db220975cba4204eb7f44e5ba2b0559874a706dae5c9b40eee58e0d kplotting-5.62.0.tar.xz"
+sha512sums="642ae00eb36cc5ff8894e8c9b527bcfb1b1be33815962a58ffff1cf8a96421dcd56020cca68276b3238d67e34983ae0f857e2474c86525d513586ca1271d2539 kplotting-5.63.0.tar.xz"