aboutsummaryrefslogtreecommitdiffstats
path: root/community/kwin/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kwin/APKBUILD')
-rw-r--r--community/kwin/APKBUILD19
1 files changed, 14 insertions, 5 deletions
diff --git a/community/kwin/APKBUILD b/community/kwin/APKBUILD
index 4fa387b749..a030715e3e 100644
--- a/community/kwin/APKBUILD
+++ b/community/kwin/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kwin
-pkgver=5.16.5
-pkgrel=2
+pkgver=5.17.0
+pkgrel=0
pkgdesc="An easy to use, but flexible, composited Window Manager"
arch="all"
url="https://www.kde.org/workspaces/plasmadesktop/"
@@ -11,12 +11,19 @@ depends="qt5-qtwayland qt5-qtmultimedia kirigami2 xorg-server-xwayland"
depends_dev="qt5-qtbase-dev qt5-qtdeclarative-dev qt5-qtscript-dev qt5-qtsensors-dev qt5-qtx11extras-dev kconfig-dev kconfigwidgets-dev kcoreaddons-dev kcrash-dev kglobalaccel-dev ki18n-dev kinit-dev knotifications-dev kpackage-dev plasma-framework-dev kwidgetsaddons-dev kwindowsystem-dev kiconthemes-dev kidletime-dev kwayland-dev kcompletion-dev kdeclarative-dev kcmutils-dev kio-dev ktextwidgets-dev knewstuff-dev kservice-dev kxmlgui-dev kactivities-dev kdecoration-dev kscreenlocker-dev breeze-dev libepoxy-dev mesa-dev wayland-dev xcb-util-cursor-dev xcb-util-image-dev xcb-util-wm-dev libinput-dev eudev-dev libdrm-dev mesa-gbm fontconfig-dev libxkbcommon-dev libxi-dev"
makedepends="$depends_dev extra-cmake-modules qt5-qttools-dev qt5-qttools-static kdoctools-dev"
checkdepends="xvfb-run"
-source="https://download.kde.org/stable/plasma/$pkgver/$pkgname-$pkgver.tar.xz"
+source="https://download.kde.org/stable/plasma/$pkgver/kwin-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
options="!check" # Broken
+prepare() {
+ default_prepare
+
+ mkdir "$builddir"/build
+}
+
build() {
- cmake \
+ cd "$builddir"/build
+ cmake "$builddir" \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
@@ -24,10 +31,12 @@ build() {
}
check() {
+ cd "$builddir"/build
CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
}
package() {
+ cd "$builddir"/build
DESTDIR="$pkgdir" make install
}
-sha512sums="26792c58dbdb6d4c452c7953f16ebd67a0115547e5cd537f4e0facf94e461845df8261a106260c30ea6a2ab9b4b98c748ddbe35ecd6de78ba3a87a1d62e05a93 kwin-5.16.5.tar.xz"
+sha512sums="1a3a596ac9d2b7b1a3e7d0679ba5229aeb6f5c38f6e827d73d2553d140942c3de1979168073a953d84bc9639c15f01afdaecee422cc5fcf4561eb3993351fc74 kwin-5.17.0.tar.xz"