aboutsummaryrefslogtreecommitdiffstats
path: root/community/kwindowsystem/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kwindowsystem/APKBUILD')
-rw-r--r--community/kwindowsystem/APKBUILD15
1 files changed, 12 insertions, 3 deletions
diff --git a/community/kwindowsystem/APKBUILD b/community/kwindowsystem/APKBUILD
index 19e3cb1f0a..ccc8b4d1ff 100644
--- a/community/kwindowsystem/APKBUILD
+++ b/community/kwindowsystem/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kwindowsystem
-pkgver=5.62.0
+pkgver=5.63.0
pkgrel=0
pkgdesc="Access to the windowing system"
arch="all"
@@ -14,8 +14,15 @@ source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kwindowsystem-$p
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
options="!check" # Test 6 hangs
+prepare() {
+ default_prepare
+
+ mkdir "$builddir"/build
+}
+
build() {
- cmake \
+ cd "$builddir"/build
+ cmake "$builddir" \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
@@ -24,11 +31,13 @@ build() {
}
check() {
+ cd "$builddir"/build
CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
}
package() {
+ cd "$builddir"/build
DESTDIR="$pkgdir" make install
}
-sha512sums="13c2f6cb02c2558bc0988a73ef6ae0e1a6d7cdcc5d7f117a115d62a99c007a2cf1e0612a854c00adc8062476da58e9500d9a07252ff6e1bfcb3cf54d7c112d8a kwindowsystem-5.62.0.tar.xz"
+sha512sums="be5102c3f48ccc1c98c9c8c42fe4d89533c2813cd50a1f6425f6cfe4b52b5450eca4d582afa59fa66bd452b93ea2e2314823caa286313f235398f986550b05e1 kwindowsystem-5.63.0.tar.xz"