aboutsummaryrefslogtreecommitdiffstats
path: root/community/latte-dock/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/latte-dock/APKBUILD')
-rw-r--r--community/latte-dock/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/community/latte-dock/APKBUILD b/community/latte-dock/APKBUILD
new file mode 100644
index 0000000000..be46e5b0cf
--- /dev/null
+++ b/community/latte-dock/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=latte-dock
+pkgver=0.9.2
+pkgrel=0
+arch="all !ppc64le !s390x" # Limited by libksysguard -> qt5-qtwebengine
+url="https://store.kde.org/p/1169519/"
+pkgdesc="A dock based on Plasma Frameworks"
+license="LGPL-2.0-or-later AND GPL-2.0-or-later"
+depends="kactivities"
+makedepends="extra-cmake-modules qt5-qtbase-dev qt5-qtdeclarative-dev libksysguard-dev
+ kactivities-dev karchive-dev kcoreaddons-dev kguiaddons-dev kcrash-dev
+ kdbusaddons-dev kdeclarative-dev kglobalaccel-dev ki18n-dev kiconthemes-dev
+ knewstuff-dev knotifications-dev plasma-framework-dev kwayland-dev
+ kwindowsystem-dev kxmlgui-dev xcb-util-dev plasma-desktop-dev"
+source="https://download.kde.org/stable/latte-dock/latte-dock-$pkgver.tar.xz"
+subpackages="$pkgname-lang"
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="3537ec6b9503802a7efbbea7ae6ddf864188ba3b73c8121b434efc527f3c3e8d8f5e68447541a867b4422ccc5e3d2af85f491807a597bdb747960e8ab983bebd latte-dock-0.9.2.tar.xz"