aboutsummaryrefslogtreecommitdiffstats
path: root/community/libmpack/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libmpack/APKBUILD')
-rw-r--r--community/libmpack/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/community/libmpack/APKBUILD b/community/libmpack/APKBUILD
new file mode 100644
index 0000000000..1f62a9392a
--- /dev/null
+++ b/community/libmpack/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=libmpack
+pkgver=1.0.5
+pkgrel=0
+pkgdesc="Simple implementation of msgpack in C"
+url="https://github.com/libmpack/libmpack"
+arch="all"
+license="MIT"
+makedepends="libtool"
+subpackages="$pkgname-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/libmpack/$pkgname/archive/$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ make
+}
+
+check() {
+ local out
+ cd "$builddir"
+
+ # Tests prints thousands lines, so print only last few when fails.
+ out=$(make test) || {
+ echo "Tests failed, printing last 50 lines of the output..."
+ printf '%s\n' "$out" | tail -n 50
+ return 1
+ }
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" PREFIX=/usr install
+}
+
+sha512sums="6e30edafcacfb580b410bc6749ed7fe8f18b3be0cb98959339853e77bc3ec0cda6df08a0f1f22768cfc773458a2ea6bcef4f0421eea55cf56c58981d13711a04 libmpack-1.0.5.tar.gz"