aboutsummaryrefslogtreecommitdiffstats
path: root/community/libndp/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libndp/APKBUILD')
-rw-r--r--community/libndp/APKBUILD40
1 files changed, 18 insertions, 22 deletions
diff --git a/community/libndp/APKBUILD b/community/libndp/APKBUILD
index 556ffb47ad..33390cfa7e 100644
--- a/community/libndp/APKBUILD
+++ b/community/libndp/APKBUILD
@@ -1,34 +1,28 @@
# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
pkgname=libndp
-pkgver=1.4
+pkgver=1.6
pkgrel=0
pkgdesc="Library for IPv6 Neighbor Discovery Protocol"
url="http://libndp.org"
arch="all"
license="GPL2.1"
-depends=""
-depends_dev=""
-makedepends="$depends_dev"
-install=""
+makedepends="autoconf automake libtool"
subpackages="$pkgname-dev $pkgname-doc"
-source="http://libndp.org/files/$pkgname-$pkgver.tar.gz
+source="$pkgname-$pkgver.tar.gz::https://github.com/jpirko/libndp/archive/v$pkgver.tar.gz
+ 0001-remove-bash-dependency.patch
fix-fd_set.patch
"
+builddir="$srcdir"/$pkgname-$pkgver
-_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
+ cd "$builddir"
+ default_prepare
+ ./autogen.sh
}
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -42,14 +36,16 @@ build() {
make || return 1
}
+check() {
+ cd "$builddir"
+ make check
+}
+
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir" install || return 1
}
-md5sums="52c708d4b8729ae6e3781b3737a85e16 libndp-1.4.tar.gz
-7b1e885680e9677de2f25707850db7dd fix-fd_set.patch"
-sha256sums="3a0be247ec024bd72fe5b40ea9491519c4023c7faf078311196fab817b2fd55f libndp-1.4.tar.gz
-401a6d2601790f136e9c7b51b49003c3994df93136c6acdb289ce377d7068942 fix-fd_set.patch"
-sha512sums="a84d4d6672bf83bcf865eef8986e7bbcc49587686c5085a5ce5f346791223ede0e60db3b990055afc4f0005182aa1b5546c459306d2955f95d00ffb68bd58766 libndp-1.4.tar.gz
-291503b1a9b21ae3e75d0048fadaa0bace989c6091ddb7238ed7920d4daa968bbd66608432de341fa2cde33d440dcd1b679bc590c7b8d91a68363f5469abc92b fix-fd_set.patch"
+sha512sums="9ecaf36656cea8b71b2864eda7e5e2d106c4e861fc7506be9ce309aabee2dfcd695c55f65ae1db4afc1d44cf20b30e1ebf84dbb15d6b39bff5d3833fed57ae19 libndp-1.6.tar.gz
+e0cdeb09b757c8b8ed199ae9178dedcbb64769fee775be73f6c704fcb7fd749a91fda6c85b11f6ffcc010cef05a5ecc1d5b334374fa5056ab1cfae170e8afd6a 0001-remove-bash-dependency.patch
+16660eaad5159056d2872f8a92296e2473ac2ef8cf663d0bb40b8bd95c2c9cdf74b94642e22abaddc58b1f8a74e8ab39a6ef6356d8226e9dca0e603440bfaee9 fix-fd_set.patch"