aboutsummaryrefslogtreecommitdiffstats
path: root/community/libnumbertext/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libnumbertext/APKBUILD')
-rw-r--r--community/libnumbertext/APKBUILD23
1 files changed, 8 insertions, 15 deletions
diff --git a/community/libnumbertext/APKBUILD b/community/libnumbertext/APKBUILD
index f434c137da..cdc447fb40 100644
--- a/community/libnumbertext/APKBUILD
+++ b/community/libnumbertext/APKBUILD
@@ -1,21 +1,14 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libnumbertext
-pkgver=1.0.3
+pkgver=1.0.5
pkgrel=0
pkgdesc="Number to number name and money text conversion library"
url="https://github.com/Numbertext/libnumbertext"
arch="all"
-license="(LGPLv3+ or BSD) and (LGPLv3+ or BSD or CC-BY-SA)"
-makedepends="autoconf automake libtool"
+license="BSD-3-Clause"
subpackages="$pkgname-dev"
-source="https://github.com/Numbertext/libnumbertext/releases/download/1.0/libnumbertext-$pkgver.tar.xz"
-builddir="$srcdir/libnumbertext-$pkgver"
-
-prepare() {
- cd "$builddir"
- default_prepare
- autoreconf -v --install --force
-}
+source="https://github.com/Numbertext/libnumbertext/releases/download/$pkgver/libnumbertext-$pkgver.tar.xz"
build() {
./configure \
@@ -24,18 +17,18 @@ build() {
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
- --localstatedir=/var
+ --localstatedir=/var \
+ --disable-static \
+ --disable-werror
make
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="0ce9c68c8d928f7c8aa13f4760360ab3077ff0923a6b34256a1ca1047b7401a7d99ac5205b80b3e57c6e693c59ccc8328e04cfebeee07794c906a1ab750a3a7a libnumbertext-1.0.3.tar.xz"
+sha512sums="4d61464f26f631d272ef7285fbb931d3931b08240b58166b7e9a28c95ff5a537ca04af4c9673541b73997339d66061858c9cd18873b4c16f9ad2ccd1b68e81a3 libnumbertext-1.0.5.tar.xz"