aboutsummaryrefslogtreecommitdiffstats
path: root/community/librdkafka/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/librdkafka/APKBUILD')
-rw-r--r--community/librdkafka/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/community/librdkafka/APKBUILD b/community/librdkafka/APKBUILD
new file mode 100644
index 0000000000..3e4e5ce958
--- /dev/null
+++ b/community/librdkafka/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Bennett Goble <nivardus@gmail.com>
+# Maintainer: Bennett Goble <nivardus@gmail.com>
+pkgname=librdkafka
+pkgver=0.9.4
+pkgrel=0
+pkgdesc="The Apache Kafka C/C++ library"
+url="https://github.com/edenhill/librdkafka"
+arch="all"
+license="BSD"
+makedepends="bash python2 libressl-dev zlib-dev"
+subpackages="$pkgname-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/edenhill/$pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr || return 1
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+sha512sums="054897d90131ba7d91f66e2929f19224ae96feabe1be69e93a87ad05864f4893aa56456c3c15a303826f0c519eab09c5cd6e0b34d76ae68db6060aa80e9bc8de librdkafka-0.9.4.tar.gz"