aboutsummaryrefslogtreecommitdiffstats
path: root/community/libre2
diff options
context:
space:
mode:
Diffstat (limited to 'community/libre2')
-rw-r--r--community/libre2/APKBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/community/libre2/APKBUILD b/community/libre2/APKBUILD
index e5cf825f27..170639090d 100644
--- a/community/libre2/APKBUILD
+++ b/community/libre2/APKBUILD
@@ -9,7 +9,6 @@ pkgdesc="Efficient, principled regular expression library"
url="https://github.com/google/re2"
arch="all"
license="BSD-3-Clause"
-options="!check"
subpackages="$pkgname-dev $pkgname-doc"
source="https://github.com/google/$_pkgname/archive/$_pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$_pkgver
@@ -19,6 +18,11 @@ build() {
make
}
+check() {
+ cd "$builddir"
+ make test
+}
+
package() {
cd "$builddir"
make DESTDIR="$pkgdir" prefix=/usr install