aboutsummaryrefslogtreecommitdiffstats
path: root/community/libsass/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libsass/APKBUILD')
-rw-r--r--community/libsass/APKBUILD15
1 files changed, 5 insertions, 10 deletions
diff --git a/community/libsass/APKBUILD b/community/libsass/APKBUILD
index 6469b7686b..5398ff2102 100644
--- a/community/libsass/APKBUILD
+++ b/community/libsass/APKBUILD
@@ -3,7 +3,7 @@
pkgname=libsass
pkgver=3.5.4
pkgrel=0
-pkgdesc="A C/C++ implementation of a Sass compiler"
+pkgdesc="C/C++ implementation of a Sass compiler"
url="http://libsass.org"
arch="all"
license="MIT"
@@ -11,31 +11,26 @@ depends=""
makedepends="autoconf automake libtool"
subpackages="$pkgname-dev"
source="$pkgname-$pkgver.tar.gz::https://github.com/sass/$pkgname/archive/$pkgver.tar.gz"
-builddir="$srcdir/$pkgname-$pkgver"
prepare() {
- default_prepare || return 1
-
- cd "$builddir"
+ default_prepare
autoreconf -vif
}
build() {
cd "$builddir"
-
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
- --disable-static \
- || return 1
- make || return 1
+ --disable-static
+ make
}
package() {
cd "$builddir"
- make install DESTDIR="$pkgdir" || return 1
+ make install DESTDIR="$pkgdir"
rm -f "$pkgdir"/usr/lib/*.la
}