aboutsummaryrefslogtreecommitdiffstats
path: root/community/libtermkey/build-static-lib.patch
diff options
context:
space:
mode:
Diffstat (limited to 'community/libtermkey/build-static-lib.patch')
-rw-r--r--community/libtermkey/build-static-lib.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/community/libtermkey/build-static-lib.patch b/community/libtermkey/build-static-lib.patch
new file mode 100644
index 0000000000..842d9ac199
--- /dev/null
+++ b/community/libtermkey/build-static-lib.patch
@@ -0,0 +1,24 @@
+--- a/Makefile
++++ b/Makefile
+@@ -70,6 +70,9 @@
+ $(LIBRARY): $(OBJECTS)
+ $(LIBTOOL) --mode=link --tag=CC $(CC) -rpath $(LIBDIR) -version-info $(VERSION_CURRENT):$(VERSION_REVISION):$(VERSION_AGE) $(LDFLAGS) -o $@ $^
+
++libtermkey.a: $(OBJECTS)
++ $(LIBTOOL) --mode=link $(CC) -o $@ $^
++
+ demo: $(LIBRARY) demo.lo
+ $(LIBTOOL) --mode=link --tag=CC $(CC) -o $@ $^
+
+@@ -112,9 +115,10 @@
+ install -d $(DESTDIR)$(LIBDIR)/pkgconfig
+ sed "s,@LIBDIR@,$(LIBDIR),;s,@INCDIR@,$(INCDIR)," <termkey.pc.in >$(DESTDIR)$(LIBDIR)/pkgconfig/termkey.pc
+
+-install-lib: $(LIBRARY)
++install-lib: $(LIBRARY) libtermkey.a
+ install -d $(DESTDIR)$(LIBDIR)
+ $(LIBTOOL) --mode=install install libtermkey.la $(DESTDIR)$(LIBDIR)/libtermkey.la
++ $(LIBTOOL) --mode=install install libtermkey.a $(DESTDIR)$(LIBDIR)/libtermkey.a
+
+ install-man:
+ install -d $(DESTDIR)$(MAN3DIR)