aboutsummaryrefslogtreecommitdiffstats
path: root/community/libwacom/disable-tests.patch
diff options
context:
space:
mode:
Diffstat (limited to 'community/libwacom/disable-tests.patch')
-rw-r--r--community/libwacom/disable-tests.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/community/libwacom/disable-tests.patch b/community/libwacom/disable-tests.patch
new file mode 100644
index 0000000000..b102859582
--- /dev/null
+++ b/community/libwacom/disable-tests.patch
@@ -0,0 +1,33 @@
+diff --git a/meson.build b/meson.build
+index 6584c86..9368567 100644
+--- a/meson.build
++++ b/meson.build
+@@ -392,13 +392,6 @@ test('svg-layout-exists',
+ args: [meson.source_root()],
+ suite: ['all'])
+
+-# meson requires that we specify all files one-by-one, so let's add a test
+-# that we can't forget about that.
+-test('data-files-in-meson.build',
+- find_program('data/check-data-in-meson.build.sh'),
+- args: [meson.source_root()],
+- suite: ['all'])
+-
+ ############### tools ###########################
+
+ executable('libwacom-list-local-devices',
+@@ -533,13 +526,6 @@ if get_option('tests')
+ message('valgrind not found, disabling valgrind test suite')
+ endif
+
+- test_deprecated = executable('test-deprecated',
+- 'test/test-deprecated.c',
+- dependencies: [dep_libwacom, dep_dl],
+- include_directories: [includes_src],
+- c_args: tests_cflags,
+- install: false)
+- test('test-deprecated', test_deprecated, suite: ['all'])
+ endif
+
+ # This is a non-optional test
+