aboutsummaryrefslogtreecommitdiffstats
path: root/community/llvm3.9/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/llvm3.9/APKBUILD')
-rw-r--r--community/llvm3.9/APKBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/community/llvm3.9/APKBUILD b/community/llvm3.9/APKBUILD
index f925ecbb96..8e18ff4ec3 100644
--- a/community/llvm3.9/APKBUILD
+++ b/community/llvm3.9/APKBUILD
@@ -28,6 +28,12 @@ source="http://llvm.org/releases/$pkgver/llvm-$pkgver.src.tar.xz
"
builddir="$srcdir/$_pkgname-$pkgver.src"
+# ARM has few failures in test suite that we don't care about currently and
+# also it takes forever to run them on the builder.
+case "$CARCH" in
+ arm*) options="!check";;
+esac
+
# NOTE: It seems that there's no (sane) way how to change includedir, sharedir
# etc. separately, just the CMAKE_INSTALL_PREFIX. Standard CMake variables and
# even LLVM-specific variables, that are related to these paths, actually
@@ -114,11 +120,7 @@ build() {
check() {
cd "$builddir"/build
- # ARM has few failures in test suite that we don't care about currently.
- case "$CARCH" in
- arm*) make check-llvm || true;;
- *) make check-llvm;;
- esac
+ make check-llvm
}
package() {