aboutsummaryrefslogtreecommitdiffstats
path: root/community/lmdb/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/lmdb/APKBUILD')
-rw-r--r--community/lmdb/APKBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/community/lmdb/APKBUILD b/community/lmdb/APKBUILD
new file mode 100644
index 0000000000..baa3d6fb55
--- /dev/null
+++ b/community/lmdb/APKBUILD
@@ -0,0 +1,50 @@
+# Contributor: Olivier Mauras <olivier@mauras.ch>
+# Maintainer: Olivier Mauras <olivier@mauras.ch>
+pkgname=lmdb
+pkgver=0.9.17
+pkgrel=1
+pkgdesc="Lightning Memory-Mapped Database"
+url="http://symas.com/mdb/"
+arch="all"
+license="custom"
+depends=""
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc $pkgname-tools"
+source="https://github.com/LMDB/lmdb/archive/LMDB_$pkgver.tar.gz
+ lmdb_make.patch
+ "
+
+_builddir="$srcdir"/$pkgname-LMDB_$pkgver/libraries/liblmdb
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+tools() {
+ mkdir -p "$subpkgdir"/usr
+ mv "$pkgdir"/usr/bin "$subpkgdir"/usr
+}
+
+md5sums="8a5501c8b8535ddd6de67e95a8633aff LMDB_0.9.17.tar.gz
+57ec2294bfbf1136f3c0380878bdb7fa lmdb_make.patch"
+sha256sums="80a08218e40f76a0485ec18c42de6f1e020b1ed0268f7cb34c69746e8d98c72c LMDB_0.9.17.tar.gz
+3e1828561bcfddab00afb0ef858c6225630730669b7f16a922eb9546b65ff28d lmdb_make.patch"
+sha512sums="2f6108364973e01f6379613c02b9fa11933d6c91eadc5ae0cad55818bc0205041d0663a5dd936d89ec651eb1de0257390d48d549d1bc24ef29d7ee57c9fcb941 LMDB_0.9.17.tar.gz
+fd88db63888eb1fd54e4ba86801ff5ff2881f642086f22ca84d7154912b150cea83b9579aeda3ae08750f0a7e3774899ef3e22ef8b95be42295a5c01f079807b lmdb_make.patch"