aboutsummaryrefslogtreecommitdiffstats
path: root/community/lua-resty-hmac/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/lua-resty-hmac/APKBUILD')
-rw-r--r--community/lua-resty-hmac/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/community/lua-resty-hmac/APKBUILD b/community/lua-resty-hmac/APKBUILD
new file mode 100644
index 0000000000..b37a929a08
--- /dev/null
+++ b/community/lua-resty-hmac/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Timo Teräs <timo.teras@iki.fi>
+# Maintainer: Timo Teräs <timo.teras@iki.fi>
+pkgname=lua-resty-hmac
+pkgver=0.02.20180101
+_commitid=989f601acbe74dee71c1a48f3e140a427f2d03ae
+pkgrel=0
+pkgdesc="HMAC functions for OpenResty"
+url="https://github.com/jkeys089/lua-resty-hmac"
+arch="noarch"
+license="BSD"
+depends="nginx-mod-http-lua lua-resty-string"
+makedepends=""
+checkdepends="perl-utils perl-test-nginx"
+source="$pkgname-$pkgver.tar.gz::https://github.com/jkeys089/$pkgname/archive/$_commitid.tar.gz
+ "
+builddir="$srcdir/$pkgname-$_commitid"
+
+package() {
+ cd "$builddir"
+ mkdir -p "$pkgdir"/usr/share/lua/common
+ make DESTDIR="$pkgdir" LUA_LIB_DIR="$pkgdir/usr/share/lua/common" install
+ rm "$pkgdir/usr/share/lua/common/resty/string.lua"
+}
+
+check() {
+ cd "$builddir"
+ #make test LUA_LIB_DIR="$builddir/tmp"
+}
+
+sha512sums="9647d14722f5870805fd10f1539ca4235de63689279c92ce6f8c0cb21c590034cb1e8dc7b7bc5f5b216a68eebae281c4b0c4055c936c045bdd0aed990889c0c6 lua-resty-hmac-0.02.20180101.tar.gz"