aboutsummaryrefslogtreecommitdiffstats
path: root/community/lua-toml
diff options
context:
space:
mode:
Diffstat (limited to 'community/lua-toml')
-rw-r--r--community/lua-toml/APKBUILD25
1 files changed, 17 insertions, 8 deletions
diff --git a/community/lua-toml/APKBUILD b/community/lua-toml/APKBUILD
index 315249b602..ec3e32484a 100644
--- a/community/lua-toml/APKBUILD
+++ b/community/lua-toml/APKBUILD
@@ -2,13 +2,18 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=lua-toml
pkgver=1.0
-pkgrel=2
+pkgrel=3
pkgdesc="TOML decoder/encoder for Lua"
url="https://github.com/jonstoler/lua-toml"
-arch="noarch !ppc64le !s390x"
+arch="noarch"
license="Happy"
depends=""
-checkdepends="luajit lua-busted"
+_checkdepends="lua-busted"
+if [ "$CARCH" == "s390x" ] && [ "$CARCH" == "ppc64le" ]; then
+ checkdepends="$_checkdepends"
+else
+ checkdepends="$_checkdepends luajit"
+fi
source="$pkgname-$pkgver.tar.gz::https://github.com/jonstoler/$pkgname/archive/v$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
@@ -20,11 +25,15 @@ done
check() {
cd "$builddir"
-
- local lver; for lver in $_luaversions jit; do
- msg "Testing on lua$lver"
- lua$lver /usr/bin/busted || return 1
- done
+ # luajit not avail for selected arches
+ if printf "$checkdepends\n" | grep -q "luajit"; then
+ if [ "$CARCH" != "ppc64le" ] && [ "$CARCH" != "s390x" ]; then
+ local lver; for lver in $_luaversions jit; do
+ msg "Testing on lua$lver"
+ lua$lver /usr/bin/busted || return 1
+ done
+ fi
+ fi
}
package() {