aboutsummaryrefslogtreecommitdiffstats
path: root/community/lua-turbo
diff options
context:
space:
mode:
Diffstat (limited to 'community/lua-turbo')
-rw-r--r--community/lua-turbo/APKBUILD7
1 files changed, 3 insertions, 4 deletions
diff --git a/community/lua-turbo/APKBUILD b/community/lua-turbo/APKBUILD
index 5ed2a2a182..cb3961c002 100644
--- a/community/lua-turbo/APKBUILD
+++ b/community/lua-turbo/APKBUILD
@@ -4,7 +4,7 @@
pkgname=lua-turbo
_jitver=2.1.0_beta3
pkgver=2.1.3
-pkgrel=0
+pkgrel=1
pkgdesc="a framework built for LuaJIT 2 and Linux"
url="https://github.com/kernelsauce/turbo"
# luajit is not available for disabled arches
@@ -36,12 +36,11 @@ prepare() {
die "cannot locate luajit APKBUILD!"
fi
# we need to fix the loading of libssl.
- # so we replace symlink with real filename
sed -i -e \
- "s|os.getenv(\"TURBO_LIBSSL\") or \"ssl\"|\"$(readlink /lib/libssl.so.47)\"|" \
+ 's|"ssl")$|"/lib/libssl.so.47")|' \
turbo/hash.lua
sed -i -e \
- "s|os.getenv(\"TURBO_LIBSSL\") or \"ssl\"|\"$(readlink /lib/libssl.so.47)\"|" \
+ 's|"ssl")$|"/lib/libssl.so.47")|' \
turbo/crypto_linux.lua
}