aboutsummaryrefslogtreecommitdiffstats
path: root/community/midori/execinfo-detect.patch
diff options
context:
space:
mode:
Diffstat (limited to 'community/midori/execinfo-detect.patch')
-rw-r--r--community/midori/execinfo-detect.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/community/midori/execinfo-detect.patch b/community/midori/execinfo-detect.patch
new file mode 100644
index 0000000000..8bb9bceb2a
--- /dev/null
+++ b/community/midori/execinfo-detect.patch
@@ -0,0 +1,18 @@
+--- ./CMakeLists.txt.orig 2014-04-21 08:00:30.090231380 +0000
++++ ./CMakeLists.txt 2014-04-21 08:02:48.048579861 +0000
+@@ -102,13 +102,8 @@
+ endif ()
+
+ # Check if execinfo.h header exists
+-string(FIND ${CMAKE_SYSTEM_NAME} "BSD" BEGIN)
+-if (${BEGIN} GREATER 0)
+- string(SUBSTRING ${CMAKE_SYSTEM_NAME} ${BEGIN} 3 BSD)
+-else()
+- set(BSD 0)
+-endif()
+-if (UNIX AND NOT BSD AND NOT DFLY)
++find_file (EXECINFO execinfo.h)
++if (EXECINFO)
+ set(VALAFLAGS ${VALAFLAGS} -D HAVE_EXECINFO_H)
+ endif ()
+