aboutsummaryrefslogtreecommitdiffstats
path: root/community/nextcloud
diff options
context:
space:
mode:
Diffstat (limited to 'community/nextcloud')
-rw-r--r--community/nextcloud/APKBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/community/nextcloud/APKBUILD b/community/nextcloud/APKBUILD
index 87d7686c1e..47795ee3ca 100644
--- a/community/nextcloud/APKBUILD
+++ b/community/nextcloud/APKBUILD
@@ -10,7 +10,7 @@ license="AGPL"
_php=php7
_php_mods="-ctype -curl -dom -gd -fileinfo -iconv -json -mbstring -openssl
-posix -session -simplexml -xml -xmlreader -xmlwriter -zlib -zip"
-depends="$_php ${_php_mods//-/$_php-}"
+depends="ca-certificates $_php ${_php_mods//-/$_php-}"
makedepends="xmlstarlet"
install="$pkgname.pre-install $pkgname.pre-upgrade $pkgname.post-upgrade"
subpackages="$pkgname-initscript $pkgname-mysql $pkgname-pgsql $pkgname-sqlite
@@ -93,8 +93,13 @@ package() {
rm -r ./$wwwdir/apps/updatenotification \
./$wwwdir/updater
+ # Replace bundled CA bundle with ours.
+ ln -sf /etc/ssl/certs/ca-certificates.crt ./$wwwdir/resources/config/ca-bundle.crt
+
install -d -m 770 -o nextcloud -g www-data \
./$confdir ./$datadir ./$basedir/apps
+ install -d -m 775 -o nextcloud -g www-data \
+ ./var/log/$pkgname
# Create symlink from web root to site-apps, so web server can find
# assets w/o explicit configuration for this layout.
@@ -107,8 +112,8 @@ package() {
install -m 660 -o nextcloud -g www-data \
"$srcdir"/$pkgname-config.php ./$confdir/config.php
- install -m644 -D "$srcdir"/$pkgname.logrotate ./etc/logrotate.d/$pkgname
- install -m775 -o nextcloud -g www-data -d ./var/log/$pkgname
+ install -m 644 -D "$srcdir"/$pkgname.logrotate ./etc/logrotate.d/$pkgname
+
# Clean some unnecessary files.
find . -name .gitignore -delete \