aboutsummaryrefslogtreecommitdiffstats
path: root/community/notmuch/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/notmuch/APKBUILD')
-rw-r--r--community/notmuch/APKBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/community/notmuch/APKBUILD b/community/notmuch/APKBUILD
index 2cfb90a868..c1e5719d0e 100644
--- a/community/notmuch/APKBUILD
+++ b/community/notmuch/APKBUILD
@@ -22,12 +22,14 @@ subpackages="
$pkgname-zsh-completion:zshcomp:noarch
$pkgname-bash-completion:bashcomp:noarch"
source="https://notmuchmail.org/releases/$pkgname-$pkgver.tar.gz
- fix-tests.patch"
-
+ fix-tests.patch
+ fix-tests-for-python3.patch"
builddir="$srcdir/$pkgname-$pkgver"
+
build() {
cd "$builddir"
- ./configure \
+
+ PYTHON=python3 ./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
@@ -128,4 +130,5 @@ py3() {
}
sha512sums="989acc5eda7d2f9512741c8ae850e34c6fbbdd5fa5fa23f25a6096250d414919007c5cfda68d6f48606c0a024692e082a28cb358e6d3fc2afc0502b5bcbf5f54 notmuch-0.25.1.tar.gz
-430e8f02b194b0582dfd7c66a2791a0071824e1d215993a6daf89c8d2a1ee7f73a6202136b1d890fc8920a4dc309ae976da8a8b8fc8b90e489d3c04f1592876c fix-tests.patch"
+430e8f02b194b0582dfd7c66a2791a0071824e1d215993a6daf89c8d2a1ee7f73a6202136b1d890fc8920a4dc309ae976da8a8b8fc8b90e489d3c04f1592876c fix-tests.patch
+a7dd888c5d08835be75986e67afcbc95c7a65c187fab5b0eb969bb36e9bbbc2d647789f106f709a38906eed51e3684a3241678ace1fc8c4b5e1cdbdd06fb6bbb fix-tests-for-python3.patch"