aboutsummaryrefslogtreecommitdiffstats
path: root/community/nxapi/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/nxapi/APKBUILD')
-rw-r--r--community/nxapi/APKBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/community/nxapi/APKBUILD b/community/nxapi/APKBUILD
new file mode 100644
index 0000000000..4163f466ba
--- /dev/null
+++ b/community/nxapi/APKBUILD
@@ -0,0 +1,47 @@
+# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
+# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
+pkgname=nxapi
+_pkgname=naxsi
+pkgver=0.54
+_ver=${pkgver/_/}
+pkgrel=0
+pkgdesc="nginx/naxsi log parser, whitelist and report generator."
+url="http://www.nginx.org | https://github.com/nbs-system/naxsi"
+arch="noarch"
+license="GPL v2"
+depends="python"
+depends_dev=""
+makedepends="python-dev"
+#subpackages="$pkgname-doc"
+source="$_pkgname-$_ver.tar.gz::https://github.com/nbs-system/naxsi/archive/${_ver}.tar.gz
+ fix-config-location.patch
+ "
+
+_builddir="$srcdir"/$_pkgname-$_ver/nxapi
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="1bc31058991268e4cfdb44e9b6d8b3b3 naxsi-0.54.tar.gz
+1ad187c532b7314e6db3a18dcb0e56bc fix-config-location.patch"
+sha256sums="9cc2c09405bc71f78ef26a8b6d70afcea3fccbe8125df70cb0cfc480133daba5 naxsi-0.54.tar.gz
+abc80d64fa48babcb99272fc7a0b15bfe887370e9f0021e64104c83c9e4ff448 fix-config-location.patch"
+sha512sums="91934bfd41495715269cc6e549d17f6da66f2bdd0c9a6821fa9096b694dd3927109c4aad2f8b327620ae7c34f76a0839ac16669cd8c65081bc01fa7f829c1d43 naxsi-0.54.tar.gz
+b2b62df3d50f03180c8720cb0008039bec45ac08d416617bb53631242b32f7d831016e6381a5b4735f5a00c4196366888123214a776470e47e1fe8c22adf45b8 fix-config-location.patch"