aboutsummaryrefslogtreecommitdiffstats
path: root/community/ocaml-findlib
diff options
context:
space:
mode:
Diffstat (limited to 'community/ocaml-findlib')
-rw-r--r--community/ocaml-findlib/APKBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/community/ocaml-findlib/APKBUILD b/community/ocaml-findlib/APKBUILD
index f35df02723..1275cb7e29 100644
--- a/community/ocaml-findlib/APKBUILD
+++ b/community/ocaml-findlib/APKBUILD
@@ -3,15 +3,15 @@
pkgname=ocaml-findlib
_pkgname=findlib
pkgver=1.8.0
-pkgrel=0
+pkgrel=1
pkgdesc="OCaml package manager"
url="http://projects.camlcity.org/projects/findlib.html"
-arch="all !x86 !armhf !armv7 !s390x" # limited by ocaml abuild
+arch="aarch64 ppc64le x86_64" # reflect ocaml aport platforms
license="MIT"
depends="ocaml ocaml-runtime"
depends_dev="$pkgname=$pkgver-r$pkgrel"
makedepends="ocaml-compiler-libs m4 ncurses-dev"
-options="textrels"
+[ "$CARCH" = "x86_64" ] || options="textrels"
subpackages="$pkgname-dev $pkgname-doc"
source="http://download.camlcity.org/download/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
@@ -20,8 +20,9 @@ build() {
cd "$builddir"
./configure \
- -sitelib /usr/lib/ocaml \
+ -bindir /usr/bin \
-mandir /usr/share/man \
+ -sitelib /usr/lib/ocaml \
-config /etc/$_pkgname.conf \
-no-camlp4
make -j1 all opt