aboutsummaryrefslogtreecommitdiffstats
path: root/community/open-vm-tools/0002-open-vm-tools-Add-disable-werror-configure-option.patch
diff options
context:
space:
mode:
Diffstat (limited to 'community/open-vm-tools/0002-open-vm-tools-Add-disable-werror-configure-option.patch')
-rw-r--r--community/open-vm-tools/0002-open-vm-tools-Add-disable-werror-configure-option.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/community/open-vm-tools/0002-open-vm-tools-Add-disable-werror-configure-option.patch b/community/open-vm-tools/0002-open-vm-tools-Add-disable-werror-configure-option.patch
new file mode 100644
index 0000000000..c2c9d0b624
--- /dev/null
+++ b/community/open-vm-tools/0002-open-vm-tools-Add-disable-werror-configure-option.patch
@@ -0,0 +1,39 @@
+From a62e4de6ff96ba55e4091a9bccbe909edc631785 Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Thu, 5 Nov 2015 13:19:20 +0000
+Subject: [PATCH 02/12] open-vm-tools: Add --disable-werror configure option
+
+Packagers will normally not want the -Werror compile option as it may
+break compilation depending on the platform specific warnings.
+
+Signed-off-by: Natanael Copa <ncopa@alpinelinux.org>
+---
+ open-vm-tools/configure.ac | 12 +++++++++++-
+ 1 file changed, 11 insertions(+), 1 deletion(-)
+
+diff --git a/open-vm-tools/configure.ac b/open-vm-tools/configure.ac
+index 325a39f5..367e4ff8 100644
+--- a/open-vm-tools/configure.ac
++++ b/open-vm-tools/configure.ac
+@@ -1218,7 +1218,17 @@ AC_C_VOLATILE
+
+ ### General flags / actions
+ CFLAGS="$CFLAGS -Wall"
+-CFLAGS="$CFLAGS -Werror"
++AC_ARG_ENABLE(
++ werror,
++ AS_HELP_STRING(
++ [--disable-werror],
++ [disable compilation with -Werror]),
++ [enable_werror="$enableval"],
++ [enable_werror="yes"])
++
++if test "$enable_werror" = "yes"; then
++ CFLAGS="$CFLAGS -Werror"
++fi
+
+ # Suppress warnings from clang when taking the address of packed struct
+ # member fields when compiling hgfsServer.c
+--
+2.19.1
+