aboutsummaryrefslogtreecommitdiffstats
path: root/community/openjdk7/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/openjdk7/APKBUILD')
-rw-r--r--community/openjdk7/APKBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/community/openjdk7/APKBUILD b/community/openjdk7/APKBUILD
index 7e1bff0227..79f0cb149c 100644
--- a/community/openjdk7/APKBUILD
+++ b/community/openjdk7/APKBUILD
@@ -128,10 +128,10 @@ build() {
# Explicitly set the C++ standard as the default has changed on GCC 6+
# and disable optimizations that lead to a broken JVM. These options
# has been adopted from the Fedora package.
- export EXTRA_CPP_FLAGS="$CFLAGS -std=gnu++98 -fno-delete-null-pointer-checks -fno-lifetime-dse"
+ export EXTRA_CPP_FLAGS="$CXXFLAGS -std=gnu++98 -fno-delete-null-pointer-checks -fno-lifetime-dse"
# CXXFLAGS doesn't make it to all calls, so we set the C++ standard
# version for C too.
- export EXTRA_CFLAGS="$CXXFLAGS -std=gnu++98 -Wno-error -fno-delete-null-pointer-checks -fno-lifetime-dse"
+ export EXTRA_CFLAGS="$CFLAGS -std=gnu++98 -Wno-error -fno-delete-null-pointer-checks -fno-lifetime-dse"
local patch
for patch in $source; do