aboutsummaryrefslogtreecommitdiffstats
path: root/community/openvas-scanner/001-cmakelist-fortify.patch
diff options
context:
space:
mode:
Diffstat (limited to 'community/openvas-scanner/001-cmakelist-fortify.patch')
-rw-r--r--community/openvas-scanner/001-cmakelist-fortify.patch21
1 files changed, 0 insertions, 21 deletions
diff --git a/community/openvas-scanner/001-cmakelist-fortify.patch b/community/openvas-scanner/001-cmakelist-fortify.patch
deleted file mode 100644
index e77214f945..0000000000
--- a/community/openvas-scanner/001-cmakelist-fortify.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 588f5d8..a98929f 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -34,6 +34,7 @@ if (POLICY CMP0005)
- endif (POLICY CMP0005)
-
- include (FindPkgConfig)
-+include(CheckIncludeFile)
-
- if (NOT PKG_CONFIG_FOUND)
- message(FATAL_ERROR "pkg-config executable not found. Aborting.")
-@@ -225,7 +226,7 @@ configure_file (tools/greenbone-nvt-sync.in tools/greenbone-nvt-sync @ONLY)
-
- ## Program
-
--set (HARDENING_FLAGS "-Wformat -Wformat-security -O2 -D_FORTIFY_SOURCE=2 -fstack-protector -Wl,-z,relro -Wl,-z,now")
-+set (HARDENING_FLAGS "-Wformat -Wformat-security -O2 -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -fstack-protector -Wl,-z,relro -Wl,-z,now")
-
- set (CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} -Werror")
- set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} ${HARDENING_FLAGS} -Wall -D_BSD_SOURCE -D_ISOC99_SOURCE -D_SVID_SOURCE -D_DEFAULT_SOURCE")