aboutsummaryrefslogtreecommitdiffstats
path: root/community/oxygen-icons/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/oxygen-icons/APKBUILD')
-rw-r--r--community/oxygen-icons/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/community/oxygen-icons/APKBUILD b/community/oxygen-icons/APKBUILD
new file mode 100644
index 0000000000..0255585554
--- /dev/null
+++ b/community/oxygen-icons/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=oxygen-icons
+_pkgname=oxygen-icons5
+pkgver=5.60.0
+pkgrel=0
+arch="noarch"
+pkgdesc="Oxygen icon theme"
+url="https://community.kde.org/Frameworks"
+license="LGPL-2.1-or-later"
+makedepends="$depends_dev extra-cmake-modules fdupes qt5-qtbase-dev"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/$_pkgname-$pkgver.tar.xz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_QCH=ON
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+sha512sums="275ee2504ac0dd49587522856ea8808a55dfad367489f4a26d6e2df406eb7ddcec78e21dede8d68099c4a36be00bf28a3fb4304f09d616185af604711809f628 oxygen-icons5-5.60.0.tar.xz"