aboutsummaryrefslogtreecommitdiffstats
path: root/community/oxygen-icons/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/oxygen-icons/APKBUILD')
-rw-r--r--community/oxygen-icons/APKBUILD20
1 files changed, 6 insertions, 14 deletions
diff --git a/community/oxygen-icons/APKBUILD b/community/oxygen-icons/APKBUILD
index a8a403891f..54a9992b5c 100644
--- a/community/oxygen-icons/APKBUILD
+++ b/community/oxygen-icons/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=oxygen-icons
_pkgname=oxygen-icons5
-pkgver=5.68.0
+pkgver=5.69.0
pkgrel=0
arch="noarch !armhf" # # armhf blocked by extra-cmake-modules
pkgdesc="Oxygen icon theme"
@@ -12,29 +12,21 @@ makedepends="$depends_dev extra-cmake-modules fdupes qt5-qtbase-dev"
source="https://download.kde.org/stable/frameworks/${pkgver%.*}/oxygen-icons5-$pkgver.tar.xz"
builddir="$srcdir/$_pkgname-$pkgver"
-prepare() {
- default_prepare
-
- mkdir "$builddir"/build
-}
-
build() {
- cd "$builddir"/build
- cmake "$builddir" \
+ cmake -B build \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_QCH=ON
- make
+ make -C build
}
check() {
- cd "$builddir"/build
+ cd build
CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
package() {
- cd "$builddir"/build
- DESTDIR="$pkgdir" make install
+ DESTDIR="$pkgdir" make -C build install
}
-sha512sums="d7ba6906823b0e4c6a724b98b587808d8136e29a7f3bdf6fdb8309cbb9bfd43bc903a79cf5629c5f5cbf15510de3526332728f538d8ff624c52c021488b4ca6c oxygen-icons5-5.68.0.tar.xz"
+sha512sums="ae4692294ef10ed4da07833953c036139d6be8ae5f8b98edbf4152326f4bf2e9bfceaabf9112f43d120ae94633175a7db9a016452f7621767ccde039317f3b1e oxygen-icons5-5.69.0.tar.xz"