aboutsummaryrefslogtreecommitdiffstats
path: root/community/patchelf/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/patchelf/APKBUILD')
-rw-r--r--community/patchelf/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/community/patchelf/APKBUILD b/community/patchelf/APKBUILD
new file mode 100644
index 0000000000..c497b8c37b
--- /dev/null
+++ b/community/patchelf/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor:
+# Maintainer: Michael Koloberdin <koloberdin@gmail.com>
+pkgname=patchelf
+pkgver=0.9
+pkgrel=1
+pkgdesc="Small utility to modify the dynamic linker and RPATH of ELF executables"
+url="https://nixos.org/patchelf.html"
+arch="all !aarch64"
+license="GPL3"
+depends=""
+makedepends="autoconf automake libtool"
+install=""
+subpackages="$pkgname-doc"
+source="${pkgname}-${pkgver}.tar.gz::https://github.com/NixOS/patchelf/archive/${pkgver}.tar.gz
+ fix-tests.patch"
+builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ cd "$builddir"
+ default_prepare
+ autoreconf -fiv || return 1
+}
+
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr || return 1
+ make || return 1
+ make -C tests -j1 check || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="${pkgdir}" install || return 1
+}
+
+md5sums="69c94a4400e930f938b754d543705eb9 patchelf-0.9.tar.gz
+39250eb2b2261bac6344b4e0bba08a9c fix-tests.patch"
+sha256sums="cf0693e794229e19edcf2299427b5a352e0f4d4f06f9d3856e30ddb0344d5ce8 patchelf-0.9.tar.gz
+7e8c1d25ee815ab0cd644c5cfe76f87b83877146a5e2252236ceb407fbcaf883 fix-tests.patch"
+sha512sums="70e615f2f705f413aab5e3eebe20ffe79743bb92381b10a8faa49f16ca24b0f9bd4095c5644f682ec94d75012ffb1b39837933faa9f3c1f1c41bdc5b9d010a30 patchelf-0.9.tar.gz
+f52c519e1b43481b44ac24060a05a1f027468627e9bf6e75055a1ae480f53a4ce141923adcaacea1370a8ef3bdbf12edbf479e348b6aecc0f0d1eba0cdf23ec8 fix-tests.patch"