aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-text-diff
diff options
context:
space:
mode:
Diffstat (limited to 'community/perl-text-diff')
-rw-r--r--community/perl-text-diff/APKBUILD20
1 files changed, 7 insertions, 13 deletions
diff --git a/community/perl-text-diff/APKBUILD b/community/perl-text-diff/APKBUILD
index 2b25867abd..70eb913542 100644
--- a/community/perl-text-diff/APKBUILD
+++ b/community/perl-text-diff/APKBUILD
@@ -4,37 +4,31 @@
pkgname=perl-text-diff
_pkgreal=Text-Diff
pkgver=1.45
-pkgrel=1
+pkgrel=2
pkgdesc="Perform diffs on files and record sets"
-url="http://search.cpan.org/dist/Text-Diff/"
+url="https://metacpan.org/release/Text-Diff"
arch="noarch"
-license="GPL PerlArtistic"
-cpandepends="perl-algorithm-diff"
-cpanmakedepends=""
-depends="$cpandepends"
-makedepends="perl-dev $cpanmakedepends"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+depends="perl-algorithm-diff"
+makedepends="perl-dev"
subpackages="$pkgname-doc"
-source="http://search.cpan.org/CPAN/authors/id/N/NE/NEILB/$_pkgreal-$pkgver.tar.gz"
+source="https://cpan.metacpan.org/authors/id/N/NE/NEILB/Text-Diff-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- cd "$builddir"
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$builddir"
make
}
check() {
- cd "$builddir"
- make test
+ make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}