aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-xml-libxml-simple
diff options
context:
space:
mode:
Diffstat (limited to 'community/perl-xml-libxml-simple')
-rw-r--r--community/perl-xml-libxml-simple/APKBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/community/perl-xml-libxml-simple/APKBUILD b/community/perl-xml-libxml-simple/APKBUILD
index ef74c4ffd3..19ce13eacd 100644
--- a/community/perl-xml-libxml-simple/APKBUILD
+++ b/community/perl-xml-libxml-simple/APKBUILD
@@ -4,7 +4,7 @@
pkgname=perl-xml-libxml-simple
_pkgreal=XML-LibXML-Simple
pkgver=0.97
-pkgrel=0
+pkgrel=1
pkgdesc="XML::LibXML based XML::Simple clone"
url="http://search.cpan.org/dist/XML-LibXML-Simple/"
arch="noarch"
@@ -18,7 +18,7 @@ source="http://search.cpan.org/CPAN/authors/id/M/MA/MARKOV/$_pkgreal-$pkgver.tar
builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- default_prepare || return 1
+ default_prepare
cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
@@ -28,7 +28,12 @@ prepare() {
build() {
cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
- make && make test
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
}
package() {