aboutsummaryrefslogtreecommitdiffstats
path: root/community/php7-oauth
diff options
context:
space:
mode:
Diffstat (limited to 'community/php7-oauth')
-rw-r--r--community/php7-oauth/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/community/php7-oauth/APKBUILD b/community/php7-oauth/APKBUILD
new file mode 100644
index 0000000000..f780fd8e5b
--- /dev/null
+++ b/community/php7-oauth/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Fabio Ribeiro <fabiorphp@gmail.com>
+# Maintainer: Fabio Ribeiro <fabiorphp@gmail.com>
+pkgname=php7-oauth
+_pkgreal=oauth
+pkgver=2.0.2
+pkgrel=1
+pkgdesc="OAuth is an authorization protocol built on top of HTTP."
+url="http://pecl.php.net/package/$_pkgreal"
+arch="all"
+license="PHP"
+depends=
+makedepends="php7-dev autoconf pcre-dev"
+install=""
+subpackages=""
+source="http://pecl.php.net/get/$_pkgreal-$pkgver.tgz"
+
+builddir="$srcdir"/$_pkgreal-$pkgver
+
+build() {
+ cd "$builddir"
+ phpize7 || return 1
+ ./configure --prefix=/usr --with-php-config=php-config7 || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make INSTALL_ROOT="$pkgdir"/ install || return 1
+ install -d "$pkgdir"/etc/php7/conf.d || return 1
+ echo "extension=$_pkgreal.so" > "$pkgdir"/etc/php7/conf.d/60_$_pkgreal.ini
+}
+
+sha512sums="b7aa9459542ec390a5420127d75607702ae6df6254f4e39acb62d35c6a39b8b7990499c279df07ce681081e455b55219c51df42fd516321f317465badf6d459d oauth-2.0.2.tgz"