aboutsummaryrefslogtreecommitdiffstats
path: root/community/php7/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/php7/APKBUILD')
-rw-r--r--community/php7/APKBUILD5
1 files changed, 5 insertions, 0 deletions
diff --git a/community/php7/APKBUILD b/community/php7/APKBUILD
index f634a39961..24aba0dd9b 100644
--- a/community/php7/APKBUILD
+++ b/community/php7/APKBUILD
@@ -305,6 +305,11 @@ pear() {
pkgdesc="PHP Extension and Application Repository"
depends="$pkgname $pkgname-xml"
+ # pecl needs xml extension and since we build it as shared, it must be
+ # explicitly declared to be loaded.
+ sed -i 's/\$INCARG/& -d extension=xml.so/' \
+ "$pkgdir"/usr/bin/pecl || return 1
+
mkdir -p "$subpkgdir"/usr/bin \
"$subpkgdir"/etc/$pkgname