aboutsummaryrefslogtreecommitdiffstats
path: root/community/php7
diff options
context:
space:
mode:
Diffstat (limited to 'community/php7')
-rw-r--r--community/php7/APKBUILD19
1 files changed, 18 insertions, 1 deletions
diff --git a/community/php7/APKBUILD b/community/php7/APKBUILD
index e44b2f139a..b9715f7021 100644
--- a/community/php7/APKBUILD
+++ b/community/php7/APKBUILD
@@ -1,5 +1,22 @@
# Contributor: Valery Kartel <valery.kartel@gmail.com>
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Valery Kartel <valery.kartel@gmail.com>
+
+# Bundled libraries
+#
+# Name | License | Location | State
+# ----------+---------+------------------------+---------
+# bcmath | LGPL2 | ext/bcmath/libbcmath | used
+# date | MIT | ext/date/lib | used
+# gd | BSD | ext/gd/libgd | used
+# file | BSD | ext/fileinfo/libmagic | used
+# libmbfl | LGPLv2 | ext/mbstring/libmbfl | used
+# oniguruma | BSD | ext/mbstring/oniguruma | used
+# pcre | BSD | ext/pcre/pcrelib | not used
+# sqlite3 | Public | ext/sqlite3/libsqlite | not used
+# libzip | BSD | ext/zip/lib | not used
+# libXMLRPC | BSD | ext/xmlrpc/libxmlrpc | used
+
pkgname=php7
_pkgreal=php
pkgver=7.1.4
@@ -8,7 +25,7 @@ _suffix=${pkgname#php}
pkgdesc="The PHP$_suffix language runtime engine"
url="http://www.php.net/"
arch="all"
-license="PHP-3"
+license="PHP-3 BSD LGPL2 MIT Zend"
options=""
depends="$pkgname-common"
depends_dom="$pkgname-xml"