aboutsummaryrefslogtreecommitdiffstats
path: root/community/php7
diff options
context:
space:
mode:
Diffstat (limited to 'community/php7')
-rw-r--r--community/php7/APKBUILD15
1 files changed, 15 insertions, 0 deletions
diff --git a/community/php7/APKBUILD b/community/php7/APKBUILD
index b9715f7021..8069b29436 100644
--- a/community/php7/APKBUILD
+++ b/community/php7/APKBUILD
@@ -89,6 +89,21 @@ prepare() {
error "Upstreram API version is now $vapi. Expecting $_apiver"
return 1
fi
+
+ # https://bugs.php.net/63362 - Not needed but installed headers.
+ # Drop some Windows specific headers to avoid installation,
+ # before build to ensure they are really not needed.
+ rm -f TSRM/tsrm_win32.h \
+ TSRM/tsrm_config.w32.h \
+ Zend/zend_config.w32.h \
+ ext/mysqlnd/config-win.h \
+ ext/standard/winver.h \
+ main/win32_internal_function_disabled.h \
+ main/win95nt.h
+
+ # Fix some bogus permissions.
+ find . -name \*.[ch] -exec chmod 644 {} \;
+
autoconf
}