aboutsummaryrefslogtreecommitdiffstats
path: root/community/php7
diff options
context:
space:
mode:
Diffstat (limited to 'community/php7')
-rw-r--r--community/php7/APKBUILD29
1 files changed, 15 insertions, 14 deletions
diff --git a/community/php7/APKBUILD b/community/php7/APKBUILD
index afe81e0090..257d605aa7 100644
--- a/community/php7/APKBUILD
+++ b/community/php7/APKBUILD
@@ -4,18 +4,19 @@
# Bundled libraries
#
-# Name | License | Location | State
-# ----------+---------+------------------------+---------
-# bcmath | LGPL2 | ext/bcmath/libbcmath | used
-# date | MIT | ext/date/lib | used
-# gd | BSD | ext/gd/libgd | used
-# file | BSD | ext/fileinfo/libmagic | used
-# libmbfl | LGPLv2 | ext/mbstring/libmbfl | used
-# oniguruma | BSD | ext/mbstring/oniguruma | used
-# pcre | BSD | ext/pcre/pcrelib | not used
-# sqlite3 | Public | ext/sqlite3/libsqlite | not used
-# libzip | BSD | ext/zip/lib | not used
-# libXMLRPC | BSD | ext/xmlrpc/libxmlrpc | used
+# Name | License | Location | State
+# ----------+---------------------+------------------------+---------
+# bcmath | LGPL-2.1-or-later | ext/bcmath/libbcmath | used
+# date | MIT | ext/date/lib | used
+# fileinfo | BSD-2-Clause | ext/fileinfo/libmagic | used
+# gd | BSD | ext/gd/libgd | used
+# hash | CC0-1.0 | ext/hash/sha3 | used
+# libmbfl | LGPL-2.1-only | ext/mbstring/libmbfl | used
+# oniguruma | BSD-2-Clause | ext/mbstring/oniguruma | used
+# pcre | BSD-3-Clause | ext/pcre/pcrelib | not used
+# sqlite3 | Public | ext/sqlite3/libsqlite | not used
+# libXMLRPC | BSD-3-Clause | ext/xmlrpc/libxmlrpc | used
+# libzip | BSD-3-Clause | ext/zip/lib | not used
# Static extensions
#
@@ -26,7 +27,7 @@
pkgname=php7
_pkgreal=php
pkgver=7.2.18
-pkgrel=0
+pkgrel=1
_apiver=20170718
_suffix=${pkgname#php}
# Is this package the default (latest) PHP version?
@@ -34,7 +35,7 @@ _default_php="yes"
pkgdesc="The PHP$_suffix language runtime engine"
url="https://secure.php.net"
arch="all"
-license="PHP-3.0 BSD LGPL-2.0 MIT Zend"
+license="PHP-3.01 BSD LGPL-2.0-or-later MIT Zend-2.0"
depends="$pkgname-common"
depends_dev="$pkgname=$pkgver-r$pkgrel autoconf pcre-dev"
# Most dependencies between extensions is auto-discovered (see _extension()).