aboutsummaryrefslogtreecommitdiffstats
path: root/community/podofo/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/podofo/APKBUILD')
-rw-r--r--community/podofo/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/community/podofo/APKBUILD b/community/podofo/APKBUILD
new file mode 100644
index 0000000000..754e0cb941
--- /dev/null
+++ b/community/podofo/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=podofo
+pkgver=0.9.4
+pkgrel=0
+pkgdesc="A C++ library to work with the PDF file format"
+url="http://podofo.sourceforge.net"
+arch="all"
+license="GPL"
+depends=
+makedepends="tiff-dev libpng-dev fontconfig-dev
+cmake lua-dev openssl-dev libidn-dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tar.gz"
+builddir="$srcdir"/$pkgname-$pkgver
+build() {
+ cd "$builddir"
+ mkdir build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr .. \
+ -DPODOFO_BUILD_SHARED=1 \
+ -DPODOFO_HAVE_JPEG_LIB=1 \
+ -DPODOFO_HAVE_PNG_LIB=1 \
+ -DPODOFO_HAVE_TIFF_LIB=1
+ make || return 1
+}
+package() {
+ cd "$builddir"/build
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="929c9d2bd367fb6cb1f178cd4eb93dd3 podofo-0.9.4.tar.gz"
+sha256sums="ccdf505fcb4904617e728b15729da8700ff38442c1dd2f24fbd52934287ff859 podofo-0.9.4.tar.gz"
+sha512sums="2f675757d76ccfe2472358b04dc4cd55e2cf00ae447731af75645c7091a338b6d91dcd4b16240b305cdbb02384ddcd38048c0e3f1700185347d4e1eb5df9ee39 podofo-0.9.4.tar.gz"