aboutsummaryrefslogtreecommitdiffstats
path: root/community/psmisc/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/psmisc/APKBUILD')
-rw-r--r--community/psmisc/APKBUILD14
1 files changed, 4 insertions, 10 deletions
diff --git a/community/psmisc/APKBUILD b/community/psmisc/APKBUILD
index 986d7d2b55..9671e8a734 100644
--- a/community/psmisc/APKBUILD
+++ b/community/psmisc/APKBUILD
@@ -8,18 +8,12 @@ arch="all"
license="BSD GPL"
depends=""
makedepends="ncurses-dev"
-install=""
subpackages="$pkgname-doc"
-source="http://downloads.sourceforge.net/psmisc/psmisc-$pkgver.tar.gz"
-
-_builddir="$srcdir"/$pkgname-$pkgver
-prepare() {
- cd "$_builddir"
- # apply patches here
-}
+source="http://downloads.sourceforge.net/psmisc/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure --prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
@@ -29,7 +23,7 @@ build() {
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir" install || return 1
}