aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-bottle/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py-bottle/APKBUILD')
-rw-r--r--community/py-bottle/APKBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/community/py-bottle/APKBUILD b/community/py-bottle/APKBUILD
new file mode 100644
index 0000000000..818b991387
--- /dev/null
+++ b/community/py-bottle/APKBUILD
@@ -0,0 +1,50 @@
+# Contributor: Paul Kilar <pkilar@gmail.com>
+# Maintainer: Paul Kilar <pkilar@gmail.com>
+pkgname=py-bottle
+_pkgname=bottle
+pkgver=0.12.9
+pkgrel=0
+pkgdesc="A fast, simple and lightweight WSGI micro web-framework"
+url="http://bottlepy.org/"
+arch="noarch"
+license="MIT"
+depends=""
+makedepends="python2-dev py-setuptools python3-dev"
+install=""
+subpackages="py3-${pkgname/py-/}:_py3 py2-${pkgname/py-/}:_py2"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python2 setup.py build || return 1
+ python3 setup.py build || return 1
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py() {
+ local python=$1
+ pkgdesc="$pkgdesc - $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+_py2() {
+ _py python2
+ replaces="$pkgname"
+}
+
+_py3() {
+ _py python3
+}
+
+
+
+md5sums="f5850258a86224a791171e8ecbb66d99 bottle-0.12.9.tar.gz"
+sha256sums="fe0a24b59385596d02df7ae7845fe7d7135eea73799d03348aeb9f3771500051 bottle-0.12.9.tar.gz"
+sha512sums="c11d3cb916a0912dcda953a25b9e3a4c6f8e68e31bbaba653f1cae0e12f6b6d827fcbc9d1dfbdb9af2e28276b0056a31fa863d3723a709911406f426d528840b bottle-0.12.9.tar.gz"