aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-cffi/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py-cffi/APKBUILD')
-rw-r--r--community/py-cffi/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/community/py-cffi/APKBUILD b/community/py-cffi/APKBUILD
new file mode 100644
index 0000000000..22b6546b6c
--- /dev/null
+++ b/community/py-cffi/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: William Pitcock <nenolod@dereferenced.org>
+pkgname=py-cffi
+_pkgname=cffi
+pkgver=1.3.0
+pkgrel=0
+pkgdesc="A foreign function interface for calling C code from python"
+url="http://cffi.readthedocs.org/"
+arch="all"
+license="MIT"
+depends="python py-cparser"
+depends_dev=""
+makedepends="python-dev py-setuptools libffi-dev"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="a40ed8c8ac653c8fc7d5603711b06eaf cffi-1.3.0.tar.gz"
+sha256sums="9daa53aff0b5cf64c85c10eab7ce6776880d0ee71b78cedeae196ae82b6734e9 cffi-1.3.0.tar.gz"
+sha512sums="2ea789d67782b2f23501bea4480f42f79e312d047e2d8c777aab8113400cfa136585aa92c0a51608a0da35cd6734bc24914fcccfc5bbdad3041aad2e9f784400 cffi-1.3.0.tar.gz"