aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-eyed3/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py-eyed3/APKBUILD')
-rw-r--r--community/py-eyed3/APKBUILD33
1 files changed, 9 insertions, 24 deletions
diff --git a/community/py-eyed3/APKBUILD b/community/py-eyed3/APKBUILD
index 5f86a2e6a5..aecde226d4 100644
--- a/community/py-eyed3/APKBUILD
+++ b/community/py-eyed3/APKBUILD
@@ -3,42 +3,27 @@ pkgname=py-eyed3
_pkgname=eyeD3
pkgver=0.7.8
pkgrel=1
-pkgdesc="A Python module and program for processing information about mp3 files"
+pkgdesc="ID3 tag editor in Python"
url="http://eyed3.nicfit.net/"
arch="noarch"
-license="GPL"
+license="GPL-3.0-or-later"
depends="python2"
depends_dev=""
makedepends="python2-dev py-setuptools"
install=""
subpackages=""
source="http://eyed3.nicfit.net/releases/$_pkgname-$pkgver.tar.gz
- eyeD3-sh.patch"
-
-_builddir="$srcdir"/$_pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+ "
+builddir="$srcdir"/$_pkgname-$pkgver
build() {
- cd "$_builddir"
- python2 setup.py build || return 1
+ cd "$builddir"
+ python2 setup.py build
}
package() {
- cd "$_builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ cd "$builddir"
+ python2 setup.py install --prefix=/usr --root="$pkgdir"
}
-md5sums="2783538edb56d7f583b7c8a5801b51dc eyeD3-0.7.8.tar.gz
-71fa0586d5521bc86778a87d5d3be924 eyeD3-sh.patch"
-sha256sums="06b956572b8d63c52db8f62447277a5647fc185b7afef9f2a918b4601db467db eyeD3-0.7.8.tar.gz
-de5176e0d1e60854195954baf8fda6426abe5409cb5affcbd732f469b2f986f7 eyeD3-sh.patch"
-sha512sums="fa0f5302f8da0ca15cd3047f97e457a8f96ed6b2d6c03bba3d0e94a11bf093c503c5ffd4cbc9191f00eeeb090e7c9ab1689c9c1b2217ddb69e41251fefabdade eyeD3-0.7.8.tar.gz
-bebc7e834efe259397a397bf8024e52f41893e6eeb4a3fa2b4e00d1559fbcca27d25576dada0e10857512ac111738fdd89a3b6ae6b025b847690ba5b76fce3e4 eyeD3-sh.patch"
+sha512sums="fa0f5302f8da0ca15cd3047f97e457a8f96ed6b2d6c03bba3d0e94a11bf093c503c5ffd4cbc9191f00eeeb090e7c9ab1689c9c1b2217ddb69e41251fefabdade eyeD3-0.7.8.tar.gz"