aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-futures
diff options
context:
space:
mode:
Diffstat (limited to 'community/py-futures')
-rw-r--r--community/py-futures/APKBUILD41
1 files changed, 0 insertions, 41 deletions
diff --git a/community/py-futures/APKBUILD b/community/py-futures/APKBUILD
deleted file mode 100644
index a80b189de9..0000000000
--- a/community/py-futures/APKBUILD
+++ /dev/null
@@ -1,41 +0,0 @@
-# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
-# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-futures
-_pkgname=futures
-pkgver=3.3.0
-pkgrel=0
-pkgdesc="Backport of the concurrent.futures package from Python 3.2"
-url="https://github.com/agronholm/pythonfutures"
-arch="noarch"
-license="Python-2.0"
-makedepends="py-setuptools"
-subpackages="py2-${pkgname/py-/}:_py2"
-source="$pkgname-$pkgver.tar.gz::https://github.com/agronholm/pythonfutures/archive/$pkgver.tar.gz"
-builddir="$srcdir"/python$_pkgname-$pkgver
-
-check() {
- python2 setup.py check
-}
-
-build() {
- python2 setup.py build
-}
-
-package() {
- mkdir -p "$pkgdir"
-}
-
-_py() {
- local python=$1
- pkgdesc="$pkgdesc - $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
-}
-
-_py2() {
- _py python2
- replaces="$pkgname"
-}
-
-sha512sums="9743291af6632192d21590f93baef7813de524c4c7a33c2da94977e58125d9c21289130bb13494fba964955a6dabdcbf5ab2721c6a0bceab70148762f533abe1 py-futures-3.3.0.tar.gz"