aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-idna/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py-idna/APKBUILD')
-rw-r--r--community/py-idna/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/community/py-idna/APKBUILD b/community/py-idna/APKBUILD
new file mode 100644
index 0000000000..47789ec335
--- /dev/null
+++ b/community/py-idna/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=py-idna
+pkgver=2.0
+pkgrel=0
+pkgdesc="IDNA 2008 and UTS #46 for Python"
+url="https://github.com/kjd/idna"
+arch="noarch"
+license="BSD"
+depends=""
+depends_dev=""
+makedepends="$depends_dev py-setuptools"
+install=""
+subpackages=""
+source="idna-$pkgver.tar.gz::https://github.com/kjd/idna/archive/v$pkgver.tar.gz"
+
+_builddir="$srcdir"/idna-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="9ef51e6e51ea91b6c62426856c8a5b7c idna-2.0.tar.gz"
+sha256sums="5858af065c0b00b6ac3265fa5c7efdf9896bccb7bbd486661941a8b1447e4eac idna-2.0.tar.gz"
+sha512sums="bea2fd4bfcc3607570e28752f95989b34ff6f875ba06231afd175d26be781e6c1388ea50af3de9b9682cadb4d5dbca232d607bd9700c857865326f87a8196ea7 idna-2.0.tar.gz"